Forum www.nestor-electronic.pl Strona Główna www.nestor-electronic.pl
Forum sterowników procesorowych- programy BASCOM
 
 FAQFAQ   SzukajSzukaj   UżytkownicyUżytkownicy   GrupyGrupy   RejestracjaRejestracja 
 ProfilProfil   Zaloguj się, by sprawdzić wiadomościZaloguj się, by sprawdzić wiadomości   ZalogujZaloguj 

Problem z przetwornikiem AC w Atmega8

 
Napisz nowy temat   Odpowiedz do tematu    Forum www.nestor-electronic.pl Strona Główna -> Pomoc w programowaniu BASCOM
Zobacz poprzedni temat :: Zobacz następny temat  
Autor Wiadomość
czyzak
Nowy


Dołączył: 25 Cze 2008
Posty: 8

PostWysłany: Sob Gru 26, 2009 12:05 am    Temat postu: Problem z przetwornikiem AC w Atmega8 Odpowiedz z cytatem

Witam. W moim układzie muszę mierzyć napięcie na kondensatorze. Gdy ładuję kondensator, przetwornik mierzy mi napięcie i wyświetla wynik. Napięcie na przetwornik dzielę przez 3 rezystorami 10k (choć planuję zwiększyć do 810k). Doświadczalnie ustawiłem tak kwant próbki że pomiar jest bardzo dokładny.

Wszystko działa gdy kondensator ładuję, bo gdy mierzę napięcie na rozładowującym się kondensatorze, początkowo mierzy dobrze, ale gdzieś w połowie lub po kilku sekundach przetwornik zauważa, że napięcie zaczyna rosnąć, gdy w rzeczywistości już dawno uciekło. Czy jest jakaś różnica gdy napięcie rośnie czy maleje? Oto kod który mi to realizuje (w pętli):
Kod:
   Start Adc
   Wart_ac = Getadc(3)
   Kwant = 0.013733
   V = Wart_ac * Kwant
   Strna = Fusing(V , "##.&&")
Powrót do góry
Zobacz profil autora Wyślij prywatną wiadomość
Wyświetl posty z ostatnich:   
Napisz nowy temat   Odpowiedz do tematu    Forum www.nestor-electronic.pl Strona Główna -> Pomoc w programowaniu BASCOM Wszystkie czasy w strefie CET (Europa)
Strona 1 z 1

 
Skocz do:  
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach


Powered by phpBB © 2001, 2005 phpBB Group